Operating system not found

Post Reply
Phillali
Posts: 4
Joined: Wed Aug 15, 2012 3:01 pm

Operating system not found

Post by Phillali »

We recently bought a batch of 8 FitPC2i with windows 7 (PN:D2G-C1600-W). After a while some units seems to crash and display a error when trying to reboot itself.
"PXE-E61: Media test failure. check cable
PXE-M0F: Exiting PXE ROM
Operating System not found"

(see attached file)

When we manually reboot the PC with the power button the PC seems ok.
Our application has to run for several days and so far some fit-PCs crashed after 1 or 2 days.
I did not touch the bios setup.

What could cause the error??

Please help!
Attachments
Operating system not found
Operating system not found
Error_FitPC2.jpg (118.73 KiB) Viewed 9969 times

gabrielh
Site Admin
Posts: 1260
Joined: Thu Jun 02, 2011 1:13 pm

Re: Operating system not found

Post by gabrielh »

What you see, is the PXE boot feature. If you have no need in the PXE boot support, you can disable it from the BIOS menu. Please try to disable that feature, and soft reboot the system several times to see if the problem persist.

Additional information will help to investigate the issue

1. What is the crash reason? Are the FitPC2i placed in environment under extreme temperatures (Hot/Cold)?
2. Do you use an SSD or HDD storage?
Gabriel Heifets

Fit-PC2/3/IntensePC support.

Phillali
Posts: 4
Joined: Wed Aug 15, 2012 3:01 pm

Re: Operating system not found

Post by Phillali »

gabrielh wrote:What you see, is the PXE boot feature. If you have no need in the PXE boot support, you can disable it from the BIOS menu. Please try to disable that feature, and soft reboot the system several times to see if the problem persist.

Additional information will help to investigate the issue

1. What is the crash reason? Are the FitPC2i placed in environment under extreme temperatures (Hot/Cold)?
2. Do you use an SSD or HDD storage?
thanks for the reply.

I will try the disable the PXE boot and see what happens. But why does the PC is not booting from the internal drive anyway? All our FitPC use a SSD storage.

The fitPC are placed in a sealed case for outdoor measurements. So, I suppose that the heat can build up. However, I'm not sure yet if it is related to the crash. Indeed, we have already used the same configuration in plain sun on a hot day without noticing any problem. The recent crash cases were not in extremed weather condition.The sealed case may be the source of the problem. What temperature the FitPC can tolerate?
Is it possible that the SSD fails as the temperature climb?

gabrielh
Site Admin
Posts: 1260
Joined: Thu Jun 02, 2011 1:13 pm

Re: Operating system not found

Post by gabrielh »

The most logic reason for this issue is the storage device failure. Once FitPC2 is unable to find an OS on a preferred device in the boot order, it skips to the next one. The most common reason of the OS absence is a drive failure.
The guaranteed FitPC2's operation temperature range is 0~70C with a SSD drive as a storage
Gabriel Heifets

Fit-PC2/3/IntensePC support.

Phillali
Posts: 4
Joined: Wed Aug 15, 2012 3:01 pm

Re: Operating system not found

Post by Phillali »

According to the tests I've run, I don't think the error was due to the heat. I tested the PC in a sealed box without noticing any problem. The CPU temperature climbed up to 80 C. A SSD failure is the most probable cause.
I have recently observed other failure on FitPCs that might point toward the same cause. We often run a application for long-term measurement (from 2 days to permanent station). The fact is our Fit-PC station crash after a while... usually after a few days. The same application run without problem on another PC.
There is this one time that I rebooted the PC (after a crash) and I had an error message every time I tried to write to the SSD.
Most of the time, we find the PC crashed with the power led on but no response to the mouse or keyboard and the sreen is usually black. Then we have to manually restart the PC (power button or cycling the power cord).
I tried to monitor the PC state before a crash occurs but everything seemed OK. The temperature was stable well under critical temperature. The CPU use was also stable around 35%.

Well, I don't know where to go from there, but we can afford to have a system crash unexpectedly after a few days.

Witty
Posts: 1
Joined: Fri Mar 15, 2013 9:09 am

Re: Operating system not found

Post by Witty »

This is an urgent request for a fix:

I have bought 10 fitPC2i (1.6GHz, 2GB RAM): 5 (five) fitPC2i, that run on SSDs and 5 that run on HDDs. The SSDs are KINGMAX SSDNOW 200 (128GB).
I can confirm that while the HDD-equipped fitPCs work flawlessly, the SSD ones (ALL OF THEM) do not work. I have extracted the SSDs, put them in an Acer Aspire laptop with absolutely no issue.
When using them in the fitPCs, in the BIOS, the disk is detected as: Generic FCR SATA Loader (picture attached).
Out of the 5 SSD fitPCs, four of them I have started today for the first time (so there is no overheating issue and out of 20 cold boot attempts, 2 or 3 of them are successfull.

I am eagerly (and desperately) waiting for a fix.
Thank you for your time.
Attachments
Bios status for the SSD fitPC2i
Bios status for the SSD fitPC2i
2013-03-15 11.19.17.jpg (862.23 KiB) Viewed 9562 times

irads
Site Admin
Posts: 2365
Joined: Mon Mar 16, 2009 2:11 pm

Re: Operating system not found

Post by irads »

It seems there is a compatibility issue between fit-PC2i and this SSD.
If you wish to send to CompuLab an SSD for testing we may be able to tell more, but given the time pressure it may be more effective to choose another SSD.
-------------------------
Irad Stavi
Forum admin

-------------------------

demoxp
Posts: 1
Joined: Thu Mar 21, 2013 12:30 pm

Re: Operating system not found

Post by demoxp »

I have the same problem as Witty with the 2 fitPC2i that i've bought. Both of them run on Kingston SSDNow V200 128 GB. It seems to be a power consumption problem, because when I've powered the SSD separately, from another PC, it worked without problems. Those SSDs have no problem with any other machine I've tested on. Also, I've tested the fitPC2i with another SSD (Kingston SSDNow V+ 200 120 GB) and it works just fine. The difference between these two SSD models, is related to the power consumption. According to the specifications of these SSDs, the V200 power consumption is 2.0 W (TYP) idle / 4.8 W (TYP) write, while the V+200 power consumption is 0.565 W (TYP) idle / 1.795 W (TYP) read / 2.065 W (TYP) write.
Could you test these configurations and reply with your results? I really need a solution for this issue.

ZaphodB
Posts: 1
Joined: Fri May 03, 2013 3:41 am

Re: Operating system not found

Post by ZaphodB »

I have had the same problem as the Phillali. It says "operating system not found" and I see the screen they posted.
Looking in the BIOS it hadn't registered the hard drive.

So I rebooted it, it restarted then a "recover mode or start windows normally" screen comes up, so I assume it found the hard drive again.
When I select the recover mode, it goes through the automatic fix sequence and says that it cannot be fixed automatically.

Any thoughts on a fix? Is it a case of trying to reinstall windows via a USB stick?

It is intended for use in a permanent monitoring station outdoors in a weather proof enclosure, however we have just been bench testing them indoors.

FitPC2i 2GB, 1.6GHz, Win7 Pro, 250GB HDD

Post Reply

Return to “fit-PC2 hardware”