FreeBSD9 (bootloader)

Post Reply
rjsparks
Posts: 1
Joined: Wed Sep 26, 2012 9:06 pm

FreeBSD9 (bootloader)

Post by rjsparks »

I've attempted to install FreeBSD9 on a fit-PC3 Pro 4GB FM-4E4U, but have not found a happy bootloader configuration.

I've tried both a normal and a zfs install. The installs themselves look good - drivers seem to all be happy (except perhaps for the wifi), but on reboot I get an underscore for a fraction of a second, and then the "Boot Menu/App Menu" screen.

Among other things, I tried adapting the 2i/zfs install at http://www.pl0rt.org/text/freebsd-on-fitpc-2i/
(also with FreeBSD8).

If anyone's further down this path and has notes to share, please let me know.

RjS

gabrielh
Site Admin
Posts: 1260
Joined: Thu Jun 02, 2011 1:13 pm

Re: FreeBSD9 (bootloader)

Post by gabrielh »

I am sorry, we haven't tested FreeBSD so far. I will give it a try an post you with an update. Also maybe other user have an experience with a FreeBSD
Gabriel Heifets

Fit-PC2/3/IntensePC support.

qwkslvr
Posts: 1
Joined: Wed May 08, 2013 11:21 pm

Re: FreeBSD9 (bootloader)

Post by qwkslvr »

Hi,
Yes, I have had the same problem. I am trying FreeBSD 9.1 and my install media boots fine and installs fine. However on reboot, I get repeated Boot Menu prompts. What Can i do to get this issue fixed?

-Q

jens
Posts: 32
Joined: Thu May 07, 2009 2:32 pm

Re: FreeBSD9 (bootloader)

Post by jens »

I had the same problem with FreeBSD 9, but realized that it is due to the use of GPT partition table. In the installer it is possible to use MBR (dos style partition table) and with this it is possible to boot.
When configuring discs in the installer avoid choosing "Use entire disc". Instead
do the manual config, and create an MBR partition table. I hope this helps.

Post Reply

Return to “Other operating systems on fit-PC3”