VMware vSphere ESXi 5.0 Hypervisor

Post Reply
johnsandiford
Posts: 12
Joined: Sat Mar 21, 2009 6:08 am

VMware vSphere ESXi 5.0 Hypervisor

Post by johnsandiford »

Looks like a great device for a VMware vSphere ESXi 5.0 Hypervisor server at home or SMB; particularly with 8GB of memory.

Has fit-PC3 been tested with ESXi 5.0? If so what were the specifications tested and/or recommendations to use a fit-PC3 as an ESXi 5.0 server? I am guessing either the LP or Pro model.

irads
Site Admin
Posts: 2365
Joined: Mon Mar 16, 2009 2:11 pm

Re: VMware vSphere ESXi 5.0 Hypervisor

Post by irads »

We have not tested vSphere in-house. If someone does, we would appreciate the feedback.
-------------------------
Irad Stavi
Forum admin

-------------------------

mirumu
Posts: 14
Joined: Thu Nov 10, 2011 8:51 am

Re: VMware vSphere ESXi 5.0 Hypervisor

Post by mirumu »

I've a copy of ESXi 5.0 around that I can try when my Fit-PC3 LP arrives. I'm planning to put Linux on mine, but I'll give ESXi a go beforehand and post what I find in this thread.

I'd hazard a guess it'll be the SATA controller VMWare will have trouble with if anything. I've not had much luck running ESXi on other AMD hardware for that reason. Usually terminates early during the install unable to find any hard drives. It'd certainly be nice if it does work on the Fit-PC3 though.

mirumu
Posts: 14
Joined: Thu Nov 10, 2011 8:51 am

Re: VMware vSphere ESXi 5.0 Hypervisor

Post by mirumu »

Well my Fit-PC3 LP arrived today and I tried out ESXi 5.0.

I'm impressed, it actually installs and works perfectly without a hitch. VMWare detects the CPU as an AMD G-T40E Brazos with both cores available, the SATA3 controller and it's drives are detected fine, the ethernet port too, and 3.7GB of RAM is available. I assume the missing RAM has been allocated for use as video memory, but I haven't yet looked in the bios to see if I can free more up. It doesn't detect my external USB DVD drive after install, but I can still create VMs using ISO images local to the VI client, or that have been loaded into the datastore.

I set up a Linux virtual machine as a test, and it actually performs pretty well. Here's some CPU benchmarks for the VM. Keep in mind these numbers are for a VM with only one CPU core enabled as single VM performance does not improve with more cores. Native Linux running directly on a Fit-PC3 will be faster.
Blowfish VM benchmark
Blowfish VM benchmark
bench1.jpg (40.6 KiB) Viewed 10269 times
Fibonacci VM benchmark
Fibonacci VM benchmark
bench2.jpg (41.5 KiB) Viewed 10269 times
Raytracing VM benchmark
Raytracing VM benchmark
bench3.jpg (41.28 KiB) Viewed 10269 times
Also here's a couple of HDparm results to show disk access speeds in the VM. The drive I've got installed currently is a fairly old and slow 5400RPM 120GB Fujitsu so I'd say these numbers are pretty good.

/dev/sda:
Timing cached reads: 1342 MB in 2.00 seconds = 671.09 MB/sec
Timing buffered disk reads: 210 MB in 3.02 seconds = 69.51 MB/sec

/dev/sda:
Timing cached reads: 1290 MB in 2.00 seconds = 644.96 MB/sec
Timing buffered disk reads: 218 MB in 3.03 seconds = 71.88 MB/sec

/dev/sda:
Timing cached reads: 1380 MB in 2.00 seconds = 689.86 MB/sec
Timing buffered disk reads: 210 MB in 3.02 seconds = 70.42 MB/sec

Hope this helps.

johnsandiford
Posts: 12
Joined: Sat Mar 21, 2009 6:08 am

Re: VMware vSphere ESXi 5.0 Hypervisor

Post by johnsandiford »

Excellent - thanks mirumu! This is what I was hoping for, I've been extremely happy with my fit-PC2 so I think a fit-PC3 configured as a ESXi server will be great.

Thanks for posting your findings and test results.

ioannism
Posts: 4
Joined: Sat Feb 04, 2012 5:48 pm

Re: VMware vSphere ESXi 5.0 Hypervisor

Post by ioannism »

I too am using it for ESXi 5. Good performance for my needs.

Any ideas when the FACE with the 4 network ports will be made available? Would we be able to upgrade the FACE ourselves? Will the network cards be the same as the main network card so that they will also be recognized by ESXi?

Thanks,
Ioannis

Nadrek
Posts: 8
Joined: Mon Apr 30, 2012 8:35 pm

Re: VMware vSphere ESXi 5.0 Hypervisor

Post by Nadrek »

At this time, I have initial reports on a Fit-PC3 Pro, BIOS 2.1.0.333_11, with the FM-4E4U 4 Ethernet FACE module, running VMWare ESXi Hypervisor 5.1.0.

The major issue I had installing was that it refused to boot from any of the front USB ports on the FACE module, nor would it boot from the outer USB ports on the rear. The bottom middle USB port on the rear appears to work the best, perhaps including the top USB port on the middle rear pair. Symptoms on the other ports are getting into the "select a device to boot" menu without issues, seeing all the devices (all boot devices on all ports DO show up correctly; USB CD-ROMs, USB flash drives, etc.), but selecting any USB port not listed results in the display cutting in and out a couple times, then the menu showing again.

However, once this was figured out, VMWare installed from a YUMI created USB flash multi-boot drive on the middle rear USB ports onto a cheap testing USB flash drive without any problems!.

The cheap USB flash drive boots into ESXi from the bottom middle rear USB port
All five ethernet ports are available to ESXi; I happen to be using the Realtek (vmnic4) for management.
The FACE module ethernet ports are, when looking directly at them, vmnic0 through vmnic3, left to right (very convenient).
7.7GB of 8GB of RAM show up.
The OCZ Vertex 4 is available for a VMFS store without issues.
Displayport display and a USB keyboard/mouse on the front FACE plate USB ports in the ESXi management interface (for configuring the management network, mainly) worked fine.
IPv6 connectivity from the VI Client worked just fine.
An initial VMWare guest creation worked well.

The AMD G-T56N does not, of course, support AMD-Vi, so there's no passthrough for the ethernet ports.

So far, so good.

kevtcg
Posts: 4
Joined: Wed Aug 14, 2013 5:03 am

Re: VMware vSphere ESXi 5.0 Hypervisor

Post by kevtcg »

Hi All

Has anyone tried to install ESXi on bios 2.1.0.333_12.2 or above? I have 4 x fitPC3's with this Bios and Everytime I try to install ESXi it installs but then comes up with a "Select Boot Device" on re-boot. Same with XEN Server

Any Pointers would be greatly appreciated

Qlaras
Posts: 7
Joined: Mon Sep 16, 2013 5:23 pm

Re: VMware vSphere ESXi 5.0 Hypervisor

Post by Qlaras »

I just recieved my Fit-PC3 last weekend, BIOS SBC_2.1.0.333_13.

Ordered the Pro Diskless; upgraded the included 4GB (2x2GB) to 16GB (2x8GB) - in the BIOS it showed the speed at 1600MHz (matching the RAM I bought) - I thought the APU/chipset was limited to 1333MHz. A welcome boost, if real. (Would make a difference for GPU speed for anything utilizing that)

I installed vSphere Hypervisor 5.1U1 (Build 1065491) onto a USB stick (16GB) from within a VM in VMWare Workstation following these instructions:
http://vmwire.com/2011/09/11/creating-v ... usb-stick/
(Basically, create an ESXi VM, install to the USB stick, shut down the VM and plug the drive into your new host, then power on for first-boot)

Came up just fine, identified the host as a CompuLab fit-PC3 with an AMD G-T56N CPU. Identified the onboard NIC just fine, I did have to set the management network to use it though. (Otherwise you won't be able to log in remotely to it)

NOTE: When you install ESXi/vSphere Hypervisor to a USB stick/MicroSD card, you need to specify a volume for logs to go to - I will be setting up an rsyslog server in my environment at home, but at work we've set up a seperate LUN just for this purpose.

Hope this helps, ask with any questions.

Post Reply

Return to “Other operating systems on fit-PC3”