mint-pc no longer boots

Post Reply
Posts: 3
Joined: Sun Jul 15, 2012 7:52 pm

mint-pc no longer boots

Post by dgrb »

My lovely new mint-pc, which I've had for a couple of months, seems to have a problem.

Having successfully moved the music and video serving over, I decided it was time to add the backup disks.

Connected everything apparently OK, but for some reason it dropped the network connection.

OK, it wouldn't come back - let's reboot.

And here is where the problems started...

Firstly, although it was obviously doing something (my HDMI-connected TV was getting a sync after several seconds) it was several minutes before the BIOS splash screen appeared. And then


I tried pressing F2 for the setup and eventually, several minutes later, the setup screen appeared and seemed responsive. There was nothing obviously wrong, but I did enabled "quick boot".

Reboot. Well, cycle the power.

Now, absolutely nothing seems to happen.

I did have problems when the machine first arrived with the displayport, which seemed to work briefly then stoppedm hence the HDMI connected TV.

But now...

Do I have a lemon, which needs to be returned, or is there something else I can try?

Seriously frustrated here...

BTW (obviously) running linux mint, but I don't see that's relevant as the system is currently not getting anywhere near booting it.

Posts: 3
Joined: Sun Jul 15, 2012 7:52 pm

Re: mint-pc no longer boots

Post by dgrb »

Update: I tried removing the 2 USB discs (3TB USB 2.0) drives I had just attached and tried again.

Some minutes later I got to the point where linux complained it couldn't mount the missing disks. Intervened manually and all came up OK. Attached the other disks and all was fine.

Now I can tell that the BIOS is doing *something* with the USB, as I can see and hear my other USB (3TB, USB 3.0) disk spinning up when I boot.

Presumably whatever it's doing is somehow dependent on the size and bandwidth of the disk and interface, hence the delay when only the USB3 disk was attached was nothing like as long as with the other 2 disks also attached (basically I gave up after about 20 minutes with apparently nothing happening).

I see that during the BIOS setup I can disable USB, but this seems like an irrevocable step, as I'd need the (USB) keyboard to get back into the setup to change it.

Does anyone know a) what the BIOS is doing and b) whether turning of USB support in the BIOS is or is not recoverable?


Site Admin
Posts: 1260
Joined: Thu Jun 02, 2011 1:13 pm

Re: mint-pc no longer boots

Post by gabrielh »

Let's start with the b)

If you will disable the BIOS level USB support, then, as stated, you will lose a keyboard control over the BIOS. To gain the control again, you will have to reset BIOS. A BIOS reset procedure is a little bit tricky, and evolve manipulations that does not covered under warranty.

a) The only thing that BIOS "do" with the hard-disks, is identifying them.
To see if this is a BIOS related issue, please try to access BIOS with the USB2 disks attached. Please hold the F2 key before powering on the mint box, and then power on it. Don't release the F2 key until you'll see the BIOS menu
Gabriel Heifets

Fit-PC2/3/IntensePC support.

Posts: 14
Joined: Mon Mar 25, 2013 8:02 pm

Re: mint-pc no longer boots

Post by jimfred »

It's a long shot but try different USB ports on the Fit.

We had problems where the Fit-PC3 would not boot if our USB serial ports were plugged in to the USB3 ports next to the power connector. When we used other USB ports, the Fit-PC3 would boot ok.

Until we figured that out, we disabled USB during boot in the BIOS. Although that allowed booting with the USB serial ports plugged into the USB3 ports, it made BIOS maintenance/modification difficult.

Post Reply

Return to “fit-PC3 hardware”