Need advice on changing resolution manually for EMGD driver

Post Reply
Posts: 2
Joined: Wed Jun 22, 2011 11:27 pm

Need advice on changing resolution manually for EMGD driver

Post by rossyp83 »


I've had a fit-PC2 for a while, but about a year ago it stopped displaying on my TV. I've recently had time to get it working again, so I've been digging around on it to try and figure out what went wrong. I can safely say I haven't fixed it and I'm now struck.

I'm connecting to an LCD TV with a max res of 1366 x 768. The manual states a Vertical Frequency of 60Hz and a Horizontal Frequency of 47.7Hz is supported at that res, I have no idea what this means.

I've followed the post by Denis to install Linux Mint (post called "Linux Mint 9 is officially supported" - ... e4cb39705d. When I boot via USB I get a 640x480 GUI, which is the only option in the Monitor drop down.

Following the steps, I update the repos, and install a bunch of packages, including what I assume is the Poulsbo driver, purge some old stuff then reboot.

I get my screen back but the TV itself displays a message saying "Not Supported".

Using Ctrl-Alt-F1 I can access the machine through a terminal, and I've grabbed my Xorg.conf and xorg.log files. I'm not that well versed in these files, but I believe the log indicates a 1920x1200 resolution was selected:

(II) EMGD(0): Using Display Configuration 0x00000021
(**) EMGD(0): Depth 24, (--) framebuffer bpp 32
(==) EMGD(0): Using gamma correction (1.0, 1.0, 1.0)
(II) EMGD(0): 60 modes passed validation checks
(--) EMGD(0): Virtual size is 1920x1200 (pitch 0)
(**) EMGD(0): Built-in mode "1920x1200": 193.2 MHz (scaled from 0.0 MHz), 74.5 kHz, 60.0 Hz
(II) EMGD(0): Modeline "1920x1200"x60.0 193.16 1920 2047 2255 2591 1200 1200 1203 1241 +vsync (74.5 kHz)
(**) EMGD(0): Built-in mode "1920x1080": 172.8 MHz (scaled from 0.0 MHz), 67.1 kHz, 60.0 Hz
(II) EMGD(0): Modeline "1920x1080"x60.0 172.80 1920 2039 2247 2575 1080 1080 1083 1117 +vsync (67.1 kHz)

Lower in the log, the first Modeline I can see that I might support is here:

(**) EMGD(0): Built-in mode "1366x768": 74.1 MHz (scaled from 0.0 MHz), 44.5 kHz, 60.0 Hz
(II) EMGD(0): Modeline "1366x768"x60.0 74.06 1366 1429 1557 1663 768 768 769 775 +hsync +vsync (44.5 kHz)

I tried to fix xorg.conf by adding a Display SubSection to the Screen Section, however I'm not convinced I added the right values. Sometimes I would get no visible change, other times I'd clearly entered something invalid and I got a GUI that suggested I launch failsafe X. This failsafe appeared to be the 640x480 I got before.

Could anybody give me advice on either:

a) Changing my installed software to fix the issue (but that's higher than 640x480)
b) How to manually force the EMGD driver to use a format my TV supports?



PS I've pasted in my xorg.conf (couldn't attach it for some reason), but I believe it may be the stock one anyway:

Section "ServerLayout"
Identifier " Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"

# Primary (First/only) display
Section "Device"
Identifier "Card0"
Driver "emgd"
VendorName "Intel(R) DEG"
BoardName "Embedded Graphics"
BusID "0:2:0"
Screen 0
VideoRam 32768
Option "PcfVersion" "1792"
Option "ConfigId" "1"
Option "SWCursor" "true"
Option "ALL/1/name" "fit-PC2 "
Option "ALL/1/General/PortOrder" "20000"
Option "ALL/1/General/DisplayConfig" "1"
Option "ALL/1/General/DisplayDetect" "0"
Option "ALL/1/General/xVideo" "1"
Option "ALL/1/General/XVideoBlend" "0"
Option "ALL/1/General/DRI" "1"
Option "ALL/1/Port/2/General/name" "DVI"
Option "ALL/1/Port/2/General/EdidAvail" "2"
Option "ALL/1/Port/2/General/EdidNotAvail" "1"
Option "ALL/1/Port/2/General/Rotation" "0"
Option "ALL/1/Port/2/General/Edid" "1"
Option "PortDrivers" "sdvo"

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24

Section "DRI"
Group 0
Mode 0666

Section "Extensions"
Option "Composite" "enable"

Section "ServerFlags"
Option "DontZap" "false"
Option "GlxVisuals" "all"
Option "IgnoreABI" "true"

Post Reply

Return to “Linux Mint”