Unknown signal during boot

Post Reply
iltsu
Posts: 8
Joined: Sat Oct 24, 2009 8:14 pm

Unknown signal during boot

Post by iltsu »

I installed Linux Mint on my fit-pc2. Problem is that it does not boot properly. During boot my TV goes black and display "unknown signal".

I actually tried installation twice with same results. Just in case I updated BIOS in between to DEVEL34X.ROM dated "23-12-2009" (my fit-pc2 is rev 1.21.).

I used Linux Mint 9 "Isadora" Gnome CD (32-bit). Created bootable USB stick with CD content. Generic Linux Mint installation went OK and booted to UI. Then I applied the fit-pc2 changes and rebooted.

First loading seem to go OK. It displays "Linux Mint 9" and the 4 dots indicate loading progress. Then screen goes black for 3-4 seconds and after that my TV gives up and says "unknown signal". The cable used is HDMI.

I have used few Ubuntu versions earlier with the same HW setup so they should play OK together.

Any help would be much appreciated.

derek
Posts: 94
Joined: Fri Oct 22, 2010 12:26 am

Re: Unknown signal during boot

Post by derek »

Maybe you are experiencing the same problem as I did. Have a read of

http://www.fit-pc.com/forum/viewtopic.php?f=18&t=2220

and see whether it seems similar.

iltsu
Posts: 8
Joined: Sat Oct 24, 2009 8:14 pm

Re: Unknown signal during boot

Post by iltsu »

Thanks for the tip! My case is indeed very similar to yours.

I managed to install read-edit and get-edit|parse-edid recognized my monitor as Sony TV. I added those details to "Monitor" section in xorg.conf and linked the Sony monitor entry to the "Screen" section. Still received the unknown signal.

Then I tried the xonf.conf from Ubuntu 9.04 instructions (http://fit-pc2.com/download/ubuntu/files/xorg.conf). Got error during bootup (too small to read) but default option booted to Linux Mint with "failsafe" xorg.conf.

Anyway, the last test confirms that it is all about getting the correct xorg.conf setup.

derek
Posts: 94
Joined: Fri Oct 22, 2010 12:26 am

Re: Unknown signal during boot

Post by derek »

In case it helps, in the Monitor section, I only added the modes. I didn't change any existing setting and I didn't add any other settings that were displayed by parse-edid.

What were the modes listed for your TV? What mode do you want to use? What is the model of your TV?

I don't think that you are getting far enough for this to be relevant but once you get it working (to the login screen) in the required mode, you may need to reconfigure various users to use that mode. Otherwise, for example, if you have previously been using a different mode on a different monitor, the user's config may select that mode at login. (I think I just edited a number of XML files, coming in via SSH.)

This situation arose because I did the whole install and configure with the fit-PC connected to a much smaller, normal computer monitor, connected via the fit-VGA. Only at the end of that process did I move it into the lounge room and hook it up to the TV - only to encounter the "unsupported signal" problem.

iltsu
Posts: 8
Joined: Sat Oct 24, 2009 8:14 pm

Re: Unknown signal during boot

Post by iltsu »

Got it working now. I did just what you suggested:
- added parse-edit reveled modes under "Monitor"
- added "Device" subsection with mode references under "Screen"

Fit-pc2 booted then nicely to Full HD mode.

Thanks for your help!

Post Reply

Return to “Linux Mint”