install linux-image fails on SSD

Post Reply
Posts: 1
Joined: Sun Nov 13, 2011 8:16 pm

install linux-image fails on SSD

Post by arjang60 »

I have tried numerous times to install a linux distro on my new fit pc2. I bought a 120 GB OCZ Vertex Plus 2.5" SATA II disk.

The installation of - in this case Mint 9 - succeeds and the reboot goes well as well.
But after a sudo apt-get update / upgrade it goes all wrong and my partiontable is gone and can't do anything other than a new install.

I 've tried Mint 9, Xubuntu 10.04 and Mint 11 several times. Also followed the howto

What happends when the upgrade runs:

Code: Select all

User postinst hook script [/usr/sbin/update-grub] exited with value 2
dpkg: error processing linux-image-2.6.35-34-fitpc2 (--configure):
 subprocess installed post-installation script returned error exit status 2
Setting up libva-x11-1 (1.0.1-3ppa1) ...
dpkg: unrecoverable fatal error, aborting:
 unable to install updated status of `libva-x11-1': No such file or directory
E: Sub-proces /usr/bin/dpkg returned an error code (2)
dkpg: unable to access dpkg status area: Read-only file system
I can't copy the output because the systems just stops. What you see above is the last I can see. The are more grub related errorr above this as well.

This happens every time. Something goes horribly wrong with grub and/or /boot I guess.

I tried also different partiontables. EXT2, EXT4, Gparted with GPT. Nothing helps.

If I then reboot I get:

error: unkown filesystem.
grub rescue>

Anybody any suggestions?

Post Reply

Return to “Linux Mint”