Corrupt graphics and UI dead [SOLVED-ish]

Post Reply
derek
Posts: 94
Joined: Fri Oct 22, 2010 12:26 am

Corrupt graphics and UI dead [SOLVED-ish]

Post by derek »

Within minutes of starting to use the fit-PC, after login, the display of one or more windows becomes "corrupt" and soon after it is no longer possible to click on anything. The mouse moves around the screen correctly but left or right mouse click does nothing. (The PC is not completely hung. I can ssh in from another computer. But the user interface is basically dead.)

It is hard to explain what I mean by corrupt. The rectangle that would be occupied by the content of the window instead is completely filled with meaningless content, mostly repetitive striping.

I am using HDMI (i.e. no VGA adapter) at 1920x1080

This may be the same problem as

http://www.fit-pc2.com/forum/viewtopic.php?f=68&t=2264

although in my case the window is much more corrupt and it is the whole window.
Last edited by derek on Tue Nov 29, 2011 6:27 am, edited 1 time in total.

gabrielh
Site Admin
Posts: 1260
Joined: Thu Jun 02, 2011 1:13 pm

Re: Corrupt graphics and UI dead

Post by gabrielh »

Hello Derek

Can you please disable the Visual Effects like described here
http://www.fit-pc2.com/wiki/index.php/K ... Linux_Mint

Thanks
Gabriel Heifets

Fit-PC2/3/IntensePC support.

derek
Posts: 94
Joined: Fri Oct 22, 2010 12:26 am

Re: Corrupt graphics and UI dead

Post by derek »

Yes, my oversight. Seems to be stable now.

Perhaps changing the Visual Effects should be moved into the installation steps, rather than being left in the "Known Issues".

Is any work being done to fix the underlying problem(s)? I'm sure the product would look better - and give a better first impression - if it were possible at least to run it at the "Normal" setting, rather than having to turn off all visual effects.

gabrielh
Site Admin
Posts: 1260
Joined: Thu Jun 02, 2011 1:13 pm

Re: Corrupt graphics and UI dead

Post by gabrielh »

Hello Derek

The problem is with the GMA500 linux drivers. The reason of placing this issue under "known issue" section, is to make users who have installed the linux mint by their own, and have encountered this issue, to be able to find the answer.

BR
Gabriel Heifets

Fit-PC2/3/IntensePC support.

derek
Posts: 94
Joined: Fri Oct 22, 2010 12:26 am

Re: Corrupt graphics and UI dead [SOLVED-ish]

Post by derek »

The problem is with the GMA500 linux drivers.
Just so as I understand then ... the problem occurs even if I have loaded and installed the kernel and drivers from the fit-PC web site? (which I have)

gabrielh
Site Admin
Posts: 1260
Joined: Thu Jun 02, 2011 1:13 pm

Re: Corrupt graphics and UI dead [SOLVED-ish]

Post by gabrielh »

That is correct
Gabriel Heifets

Fit-PC2/3/IntensePC support.

Post Reply

Return to “Linux Mint”