Boot forever - Your disk drives are being checked for errors

Post Reply
derek
Posts: 94
Joined: Fri Oct 22, 2010 12:26 am

Boot forever - Your disk drives are being checked for errors

Post by derek »

From time to time during boot the following message comes up

"Your disk drives are being checked for errors
This may take some time"

when in fact it seems that "This will take forever" is more accurate.

It seems as if this is a known Mint Linux 9 problem. There is even some suggestion that this has been fixed.

This is particularly problematic for me as this fit-PC is normally without keyboard, video or mouse. (Hence the real scenario is ... from time to time boot never completes and I have to go and plug keyboard and video in to find out what has gone wrong and cancel the fsck.)

I am running kernel 2.6.35-34-fitpc2

My question is: Has it been fixed? If it has been fixed, how do I get this fix? Is it a kernel problem? mintupdate isn't offering any additional updates i.e. software seems to be completely up to date.

I think a workaround would be to disable the file system integrity checking during boot but that is a fairly poor workaround.

Denis
Posts: 301
Joined: Sun Apr 26, 2009 3:24 pm

Re: Boot forever - Your disk drives are being checked for er

Post by Denis »

Please open /etc/fstab file, find line describing your storage device. It looks like this:

Code: Select all

/dev/sda1          /               ext3    errors=remount-ro 0       1
Change the last number "1" to "0"

Code: Select all

/dev/sda1          /               ext3    errors=remount-ro 0       0
It disables checking for errors during boot.
Compulab's Linux support

derek
Posts: 94
Joined: Fri Oct 22, 2010 12:26 am

Re: Boot forever - Your disk drives are being checked for er

Post by derek »

Yes, thanks, I know that I could just disable the checking.

But what about getting a fix? Is this a kernel issue?

gabrielh
Site Admin
Posts: 1260
Joined: Thu Jun 02, 2011 1:13 pm

Re: Boot forever - Your disk drives are being checked for er

Post by gabrielh »

Hello Derek

Please bootup from a live linux distribution. After loading process complete, run some check tool for hdd e.g. e2fsck. It should fix the problem

BR

Gaby
Gabriel Heifets

Fit-PC2/3/IntensePC support.

derek
Posts: 94
Joined: Fri Oct 22, 2010 12:26 am

Re: Boot forever - Your disk drives are being checked for er

Post by derek »

There is nothing wrong with the file system. Linux just likes to check the file system after every X boots(?). This is a good thing - as a precautionary measure.

I know that I can boot a live CD and check the root file system that way - but that is not convenient and is quite slow to boot up (and it also won't actually stop the problem occurring) and relies on a person remembering to do it from time to time.

I know that I can disable the file system check at bootup - but that is not good practice.

Putting the above two workarounds together should work around the problem but is a poor solution.

Is there some way to get the fix for this?

There is some evidence that this is a known problem and that it has been fixed.

Will Compulab ever produce an updated kernel that may pick up this and any number of other fixes?

gabrielh
Site Admin
Posts: 1260
Joined: Thu Jun 02, 2011 1:13 pm

Re: Boot forever - Your disk drives are being checked for er

Post by gabrielh »

What I mean, is that something went wrong during the conventional file check. Please try to run the file check procedure from a live system, and to if the this work around fixes the "boot forever" issue

BR
Gabriel Heifets

Fit-PC2/3/IntensePC support.

derek
Posts: 94
Joined: Fri Oct 22, 2010 12:26 am

Re: Boot forever - Your disk drives are being checked for er

Post by derek »

There seems to be a lot of chatter about this behaviour so I doubt that it is anything to do with the file system on my particular fitPC but I will boot from another disk and fsck the original root disk and then boot from the original disk. (Because the boot time fsck is every X boots or every Y days the problem would not normally reoccur immediately.)

Some discussion is here

https://bugs.launchpad.net/linuxmint/+bug/583923
http://forums.linuxmint.com/viewtopic.php?f=46&t=48011

gabrielh
Site Admin
Posts: 1260
Joined: Thu Jun 02, 2011 1:13 pm

Re: Boot forever - Your disk drives are being checked for er

Post by gabrielh »

Hello

Please update me upon the progress

Thanks
Gabriel Heifets

Fit-PC2/3/IntensePC support.

derek
Posts: 94
Joined: Fri Oct 22, 2010 12:26 am

Re: Boot forever - Your disk drives are being checked for er

Post by derek »

Hmmm. Now I'm confused.

The fitPC used to be in the lounge room, connected to the TV (not usually on) via HDMI and without a keyboard and mouse. From time to time, it would hang during boot. Switching on the TV would show the claimed message. Plugging in a keyboard and pressing C would get the fitPC on its way.

Due to a number of problems, I've moved the fitPC back into the workroom, connected to a computer monitor via VGA, with a keyboard and mouse. Now when the file system gets checked, I get no message on the screen but the process completes.

Too many things have changed between then and now (including multiple reinstalls and a change of internal disk, addition of keyboard, mouse, change of monitor - as well as any number of software updates) to pin this down.

If I can ever sort out other issues and get the fitPC back to the lounge room, I'll see whether it starts happening again.

One for the Journal of Irreproducible Results maybe.

gabrielh
Site Admin
Posts: 1260
Joined: Thu Jun 02, 2011 1:13 pm

Re: Boot forever - Your disk drives are being checked for er

Post by gabrielh »

Hello

Very weird. I will be glad to hear an updates from you about your issue.
Thank you for posting us
Gabriel Heifets

Fit-PC2/3/IntensePC support.

Post Reply

Return to “Linux Mint”