serial to usb on fit_pc slim

fit-PC Slim owners are welcome to post questions here.
Post Reply
Posts: 1
Joined: Tue Jul 26, 2011 10:59 pm

serial to usb on fit_pc slim

Post by cfowler »

I'm attaching a serial device (rs232) through an adapter to a usb port on a fit-pc slim. I have done this on at least 20 different computers and versions of linux with no problems. The problem with the fit-pc is that the reading of the port hangs. Maybe 0 characters (all ascii), part of a line, or a full line of data. But then if it does read more than one line, it will read data continuously for days with no problems.
I've tried using both "cat /dev/ttyUSB0" or a "c" program. I have tried different usb2serial adapters, different baud rates from 115200 down to 38400 and each of the 3 usb ports. on the fit-pc.
I have checked all the options with the stty command and see nothing out of place.
I'm lost as what to try next.
Any help will be appreciated.

Site Admin
Posts: 1260
Joined: Thu Jun 02, 2011 1:13 pm

Re: serial to usb on fit_pc slim

Post by gabrielh »

We are not familiar with this issue, and unfortunately, during the EOL of the product, we are unable to support it. Maybe other users will share their experience
Gabriel Heifets

Fit-PC2/3/IntensePC support.

Post Reply

Return to “fit-PC Slim questions”