Ubuntu 9.10 supported

Posts: 17
Joined: Fri Nov 20, 2009 7:23 am

Re: Ubuntu 9.10 supported

Post by billyzelsnack »

Success. I now finally have wireless! Video does seem faster, but it could be my imagination.

I only did linux-image-2.6.31-34-fitpc2 and I did not purge anything.

Do I need xserver-xorg-video-poulsbo to get video hardware acceleration?

Posts: 17
Joined: Fri Nov 20, 2009 7:23 am

Re: Ubuntu 9.10 supported

Post by billyzelsnack »

More success! I have the video drivers working now.

Installed the poulsbo driver on its own, but before I rebooted I put the desktop into 640x480 and now it worked!

Trying out other modes ( and letting it auto-switch back if they fail ) it looks like I can only go up to 1024x768 even though my monitors will do higher. When I do go higher and it fails it gives me the "out of range" message from before. So it might of been working previously. I just did not know how to change the resolution from the shell ( xrandr said the display was missing. )

Posts: 2
Joined: Sat Dec 19, 2009 7:27 am

Re: Ubuntu 9.10 supported

Post by John_K »

thanks a heap - this worked a treat for me.
I am running 9.10 server with gui in 1680x1050 mode and it seems to scroll very nicely now.
I'd been trying ubuntu forums for some time but only managed to get a low-res display.

I still can't seem to get any visual effects enabled however.
Any clues?



Posts: 1
Joined: Tue Mar 23, 2010 10:16 pm

Re: Ubuntu 9.10 supported

Post by akjim »

I have tried to install Ubuntu 9.10, following these directions and can not make it work after removing generic image and sources I get a non functioning system or the same as the start. I did not do this last step and got a functioning system with some glitches that seem to be increasing.

I get a thud when applications use sound
Glitches in video play back
start up screens are no longer full screen

Posts: 2
Joined: Fri Mar 26, 2010 2:37 am

Re: Ubuntu 9.10 supported

Post by dgux »

akjim et. al,

My system was functioning after the base Ubuntu 9.10 install, however after adding the sources, removing the 'unsupported' sources, and rebooting I now have no video.

I'll post again if I find some answers.

Posts: 57
Joined: Sun Jan 10, 2010 11:17 am

Re: Ubuntu 9.10 supported

Post by radioxid »

Hi, my system is now up and running, playing files around 6GB nearly well...

But (I've got the 1.1GHz & 1GB RAM : fit-pc2 Value) it seems that gmplayer is wasting my CPU:
spud@nabuntu:~$ top

top - 09:36:36 up 4 days, 13:47, 2 users, load average: 3.39, 3.07, 2.21
Tasks: 155 total, 2 running, 153 sleeping, 0 stopped, 0 zombie
Cpu(s): 85.9%us, 13.7%sy, 0.0%ni, 0.0%id, 0.0%wa, 0.3%hi, 0.0%si, 0.0%st
Mem: 1017504k total, 853804k used, 163700k free, 62544k buffers
Swap: 1124508k total, 36748k used, 1087760k free, 392992k cached

31976 spud 20 0 64764 14m 7996 R 49.6 1.5 1976:17 gmplayer
576 root 20 0 566m 63m 53m S 26.7 6.4 35:16.86 Xorg
9946 spud 20 0 687m 73m 20m S 16.7 7.4 1:25.18 chromium-browse
9985 spud 20 0 112m 14m 10m S 4.5 1.4 0:02.98 gnome-terminal
10008 spud 20 0 2472 1180 880 R 1.0 0.1 0:00.35 top
9821 spud 20 0 414m 50m 26m S 0.6 5.1 0:38.89 chromium-browse
903 spud 20 0 23416 8768 7084 S 0.3 0.9 4:40.55 geyes_applet2
1 root 20 0 2644 908 548 S 0.0 0.1 0:02.13 init
2 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kthreadd
3 root RT -5 0 0 0 S 0.0 0.0 0:00.00 migration/0
4 root 15 -5 0 0 0 S 0.0 0.0 1:11.97 ksoftirqd/0
5 root RT -5 0 0 0 S 0.0 0.0 0:00.00 watchdog/0
6 root 15 -5 0 0 0 S 0.0 0.0 1:21.56 events/0
7 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 khelper
8 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 async/mgr
9 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kintegrityd/0
10 root 15 -5 0 0 0 S 0.0 0.0 0:02.15 kblockd/0
Here it only consums around 50% but it usually goes up to 97%!!
I need to insist on the fact that the beast isn't playing anything or doing something...

Also, I can't display subtitles with MPlayer. And seems that MPlayer knows much less codecs than VLC (: it plays anything that don't spot "f_code non-matching". But often it's a bit fuzzy and not as smooth as VLC). Still, I believe that MPlayer is the best to play movies but I'm stuck with VLC most of the time; and VLC knows how to crash or cut sound. Maybe this last problem is due to pulseaudio and I read that we can replace it with esound.

Posts: 1
Joined: Tue Jun 22, 2010 7:32 am

Re: Ubuntu 9.10 supported

Post by dreamstogo »

Hello Everyone,

I just received my Fit PC2 and decided to go for the upgrade. No problem with that, worked well by following the instructions provided. Thank you.

I have the fit PC2 connected to my HD television which has a native resolution of 1920*1080.

The fit PC2 is connected to my home network in order to share the videos and music on my server. The server contains iso images of various films.

I have also installed VLC, but I am not sure that it is VAAPI enabled.

Here are some observations,

MPlayer crashes on some isos but not all. "Mplayer interrupted by signal 6 in module decode_video" I have experimented by trying all the video modes on the preferences video tab and by changing the decode parameters. No luck.

Mplayer does not seem to support DVD menus when it will read the iso, so you cannot start the film.

I installed VLC, it plays all isos but,

at 1920*1080 resolution the playback is not smooth, images jerk and it seems that not all frames are displayed.

at 1280*720 resolution the playback is smooth but every few seconds the playback freezes for some micro seconds before resuming again.

So it seems that VLC is my best bet.

Does anyone have any tips that may get Mplayer working on all isos and with DVD menu working?

Does anyone have any tips about why VLC has these playback problems?

Thanks for your help.

Posts: 29
Joined: Wed Nov 25, 2009 11:26 am

Re: Ubuntu 9.10 supported

Post by Zibeo »

For some reason when I do the last step :
sudo apt-get purge linux-generic linux-image-generic linux-headers-generic linux-image-$(uname -r) linux-headers-$(uname -r) && sudo apt-get autoremove

and then reboot, I get a flashing login screen :(

Posts: 162
Joined: Thu Jul 22, 2010 2:02 pm

Re: Ubuntu 9.10 supported

Post by fly »

Ubuntu 9.10 is approaching its EOL date -- see http://fit-pc2.com/forum/viewtopic.php?f=43&t=2168

Posts: 229
Joined: Mon Sep 24, 2012 6:54 pm

Re: Ubuntu 9.10 supported

Post by vtailor »

Gee, I managed to get the kernel and xorg installed on my 9.10 initial setup, then I copied the initrd from the initial kernel to the fit-pc2 initrd. In other words, I fudged the initrd, because there is no initrd to download. Only real problem is that keyboard and mouse don't register, so no way to log in to the system, and who knows what else. Basically, I wanted to see how a real xorg-psb on the gma500 of yore stacks up against doing a modern Slackware setup with only the kernel doing the graphics and an fbdev graphics driver. Judging from the tenor of the discussions, I don't think I would be overly impressed.

Anyway, I am doing this from my z510 fit-pc2 box running vesa mode on the system, not too bad. And, don't forget that xine works on practically any setup in full screen, no mplayer funny stuff.

Post Reply

Return to “Ubuntu 9.10”