Page 1 of 1

Please help me make it play 1080p content

Posted: Tue Mar 02, 2010 12:07 pm
by ypnos
Hello folks,

I need your help on this one. The purpose of my Fit-PC2 is to play HD content. I tried several options so far with mild success:

* First I tried the preinstalled Ubuntu 8.04. I figured that it had some minor issues and I was not 100% convinced by the smoothness of the trailer samples I found on disk. In the forums it was claimed that 9.10 works quite well now so I upgraded.

* With Ubuntu 9.10, video performance was worse. Scrolling in applications etc. was far from slick (I noted the recommendation to not use firefox. Scrolling is not my concern here, however, it is just another impression about the graphics 2D acceleration). Video playback of some heavy, but complient 1080p files was mixed (some stutter visible). Same videos do not play well with a Core 2 Duo 2.6, but play flawlessly with Quadro FX mobile GPU). I had two other issues as well (some reported in the forums already by others):
- Playing 720p videos gives a one pixel green line at the bottom
- After some minutes of playback, the player segfaults and va is not available anymore until next boot

* After that I tried Mandriva One, which sports the old PSB driver (that worked better before in Ubuntu 8.04). Now 2D acceleration was back to expectations. I also got stable video playback to work. However, in 1920x1080 resolution, the screen tends to flicker, especially under load which occurs... guess what... during video playback. I was told this is a known problem with old PSB driver.

* As a last resort, I installed Windows 7 Professional. First with intel driver from Fit-PC download section, now with current revision 2023. I tried PowerDVD which is said to come with GMA 500 acceleration since a specific build number. I installed newest version, luckily Cyberlink offers 30-days money back when you order on ther website with your credit card. It somehow managed to play the files, as in more then still frames. Also as in far less then 24 fps.
Next I learnt about DXVA accceleration and installed K-Lite codec pack. I had lots of confusion going on about how to make sure it will use the right (DXVA capable) codec, not do intermediate mangling and so on. I never got it to work as expected. In early tries it only produced stills. In my latter tries, where I made sure that only DXVA codecs are present, it still does not give smooth playback.
Then I tried DXVAChecker tool. A great tool which I can only recommend! DXVA enables you to actually try different DXVA options on a video you provide. It plays the video and shows you the FPS. Apart from two WMV test samples that did not work well (a cheesy trailer and a nVidia PureVideo advert) I tried the I Am Legend trailer which was also found on preinstalled disk. This time it worked, giving constant 24 fps. After that I also found that original Windows Media Player is able to play this file (not the others) at 24 fps. At least.

My question for you lucky guys out there is: How did you get it running? I mean, in a reliable fashion. Do you see what I may have overlooked? I don't care if your solution works on Linux XY or Windows (although I would prefer Linux).

Thank you for your help!


Re: Please help me make it play 1080p content

Posted: Mon Mar 08, 2010 8:22 am
by irads
I think the most significant setup you didn't try is what the manufacturer recommends - fit-PC2 XP HD ... pc2-xp-hd/

Re: Please help me make it play 1080p content

Posted: Mon Mar 08, 2010 12:12 pm
by ypnos
Yep, true, I skipped on XP and thought 7 would have superiour support. Should probably reconsider that!

Re: Please help me make it play 1080p content

Posted: Mon Apr 05, 2010 8:14 pm
by ypnos
The day before yesterday was the first time I got a full-length HD video played with only one minor issue on the Fit-PC2. 8-)

It was Watchmen Ultimate Cut in 1080p. A well-mastered movie with quite demanding scenes in it.

I had less luck with other movies, interestingly only 720p. Heavy tearing in most of the scenes. Is this probably a known (software) problem and a resolution in sight?

I used Arch Linux with kernel 2.6.31.