My Fitlet2 is (almost?) bricked!

Moderator: Andrey.Mazlin

Post Reply
Posts: 1
Joined: Tue Feb 07, 2023 9:39 pm

My Fitlet2 is (almost?) bricked!

Post by Richard.Gaudio »

Hi all, bonehead here.

In an attempt to get PFSense 2.6.0 (FreeBSD 12.3) to boot without a monitor, I disabled the integrated GPU in the BIOS. Now I have no video--including no BIOS video.

Apparently there is no hardware method to factory reset the BIOS? Therefore, I tried to update the BIOS (from FLT2. to FLT2. with the blank M.2 SSD method in the wiki. Unfortunately this fails. I tried all four combinations of MBR/GPT and bootable/non-bootable. I must have set the BIOS to Legacy boot instead of UEFI.

Is there a Legacy boot method to update the BIOS? or
A way to switch the BIOS from Legacy to UEFI (timed keystrokes?) or
Another way to recover from this genius move?


Part Number: FITLET2-CE3930
Serial Number: 1200102-06621
AMI BIOS: FLT2., 2018/09/17 14:38:57
RAM: Crucial CT102464BF160B, 8GB DDR3/DDR3L
SSD: Transcend TS128GMTS430S, 128GB SATA III MTS430S 42 mm M.2

Posts: 97
Joined: Tue May 05, 2020 7:02 am

Re: My Fitlet2 is (almost?) bricked!

Post by Andrey.Mazlin »

Andrey Mazlin, Application Support Engineer
Useful links:
Support Wiki:
Support mail:

Post Reply

Return to “fitlet2 hardware”