pre-built debian image, Legacy mode

Post Reply
edavid
Posts: 7
Joined: Tue Apr 23, 2019 11:46 am

pre-built debian image, Legacy mode

Post by edavid »

I have been using a pre-built Debian image on plenty on different hardware without issues, but it doesn't work on the fitlet2.
There's no UEFI so I tried the BIOS setting to boot exclusively in legacy mode. And just to be sure also selected Linux as operating system, even though it doesn't seem to be important.
I tried plenty of combinations without success

To be sure the image is not the problem. I tried to install Debian the regular way, which works perfectly in UEFI mode.
When the BIOS is in Legacy mode, the installation works perfectly, but the system doesn't boot and is not even visible in the boot section of the BIOS

Is there any BIOS settings I missed

The BIOS version out of the box is FLT2.0.46.01.00

fred44nl
Posts: 29
Joined: Tue Jul 24, 2018 8:37 am

Re: pre-built debian image, Legacy mode

Post by fred44nl »

I got my fitlet2 from Compulab in july 2018
I downloaded Debian 9 - Stretch and installed it.
don't know the bios-version, nor the booting mode.
it simply works.

the only thing I have found, is that it does not boot, when it has been powered down, without disconnecting the power-supply.
my solution is, to hold down the power-switch until the led goes off completely.
after that, it will boot normally.

edavid
Posts: 7
Joined: Tue Apr 23, 2019 11:46 am

Re: pre-built debian image, Legacy mode

Post by edavid »

More details now :
Even if Legacy mode set in the BIOS, Debian installer makes a EFI partition.
after putting back the BIOS in UEFI mode then it boots properly
So this was a bad test.

My pre-built image still doesn't boot whatever I do in the BIOS

tamir
Site Admin
Posts: 419
Joined: Mon Dec 25, 2017 4:21 pm

Re: pre-built debian image, Legacy mode

Post by tamir »

In order to enable Legacy support you'd need to configure CSM support to Enabled and have all the settings set to "Legacy"
It is advisable to move towards UEFI since in next generation platforms Legacy would not be supported anymore.

To enable CSM support please follow the below:

Enter the BIOS menu by tapping DEL on startup:

1. Advanced
2. CSM configuration
3. CSM support - [Enabled]
4. Set all configurations in this menu to [Legacy]

edavid
Posts: 7
Joined: Tue Apr 23, 2019 11:46 am

Re: pre-built debian image, Legacy mode

Post by edavid »

Thank you so much Tamir. It works perfectly.
UEFI is on our roadmap. We've been postponing this for way too long

tamir
Site Admin
Posts: 419
Joined: Mon Dec 25, 2017 4:21 pm

Re: pre-built debian image, Legacy mode

Post by tamir »

Glad I could assist.

Post Reply

Return to “General fitlet2 questions”