Workaround not working for "Serial port name bug on fitlet2 with Atom CPU" (Linux Mint)

Moderator: Andrey.Mazlin

Post Reply
David.Cross
Posts: 1
Joined: Sun Sep 05, 2021 6:52 am

Workaround not working for "Serial port name bug on fitlet2 with Atom CPU" (Linux Mint)

Post by David.Cross »

Hi,

Can't get the the mini-serial port working on fitlet2 using the temporary solution described here:
http://www.fit-pc.com/wiki/index.php/Li ... h_Atom_CPU

Have installed the temporary solution as described with no errors, and a new serial port /dev/ttyHS1 seems to have been created as expected, but when I test the serial post using a loopback connecter attached to RS232 adapter cable [ulr]https://fit-iot.com/web/product/rs232-adapter[/url] I notice the following issues:

1. UART state not as expected:
- port/interrupt 5 (expected RTS|CTS|DTR, seeing CTS)
- port/interrupt 6 (expected RTS|DTR, seeing CTS)
2. characters appear on a different UART port/interrupt (expected 6, seeing 7)
3. number of characters is different (expected tx:10 rx:10, seeing tx:2 rx:1 brk:1)

Is the serial port config correct?
Is the loopback connector config correct?

The test steps, serial ports stats/status, and RS232 loopback connector config are shown below:

root@edge-000001:~# echo "12345678" > /dev/ttyHS1

root@edge-000001:~# cat /proc/tty/driver/serial | grep -v unknown
serinfo:1.0 driver revision:
4: uart:16550A mmio:0x7FFFF10000 irq:4 tx:0 rx:0
5: uart:16550A mmio:0x7FFFF0E000 irq:5 tx:0 rx:0 CTS
6: uart:16550A mmio:0x280000000 irq:6 tx:0 rx:0
7: uart:16550A mmio:0x7FFFF0C000 irq:7 tx:2 rx:1 brk:1 CTS

root@edge-000001:~# dmesg | grep tty
[ 8.936445] dw-apb-uart.8: ttyS4 at MMIO 0x7ffff10000 (irq = 4, base_baud = 115200) is a 16550A
[ 8.956044] dw-apb-uart.9: ttyS5 at MMIO 0x7ffff0e000 (irq = 5, base_baud = 115200) is a 16550A
[ 8.976105] dw-apb-uart.10: ttyS6 at MMIO 0x280000000 (irq = 6, base_baud = 115200) is a 16550A
[ 8.996052] dw-apb-uart.11: ttyS7 at MMIO 0x7ffff0c000 (irq = 7, base_baud = 115200) is a 16550A
[ 12.143937] ttyS6 - failed to request DMA
[ 12.203922] ttyS7 - failed to request DMA

root@edge-000001:~# setserial -g /dev/tty*
/dev/ttyS0, UART: unknown, Port: 0x03f8, IRQ: 4
/dev/ttyS1, UART: unknown, Port: 0x02f8, IRQ: 3
/dev/ttyS2, UART: unknown, Port: 0x03e8, IRQ: 4
/dev/ttyS3, UART: unknown, Port: 0x02e8, IRQ: 3
/dev/ttyS4, UART: 16550A, Port: 0x0000, IRQ: 4
/dev/ttyS5, UART: 16550A, Port: 0x0000, IRQ: 5
/dev/ttyS6, UART: 16550A, Port: 0x0000, IRQ: 6
/dev/ttyS7, UART: 16550A, Port: 0x0000, IRQ: 7

root@edge-000001:~# ls -l /dev/ttyS? /dev/ttyH*
-rw-r--r-- 1 root root 9 Oct 9 18:03 /dev/ttyHS1
crw-rw---- 1 root dialout 4, 64 Oct 9 17:37 /dev/ttyS0
crw-rw---- 1 root dialout 4, 65 Oct 9 17:37 /dev/ttyS1
crw-rw---- 1 root dialout 4, 66 Oct 9 17:37 /dev/ttyS2
crw-rw---- 1 root dialout 4, 67 Oct 9 17:37 /dev/ttyS3
crw-rw---- 1 root dialout 4, 68 Oct 9 17:37 /dev/ttyS4
crw-rw---- 1 root dialout 4, 69 Oct 9 17:37 /dev/ttyS5
crw-rw---- 1 root dialout 4, 70 Oct 9 17:37 /dev/ttyS6
crw-rw---- 1 root dialout 4, 71 Oct 9 17:37 /dev/ttyS7

root@edge-000001:~# cat /dev/ttyHS1
12345678

RS232 Adapter Cable D9 Male (loopback connector config)
1 - Tx (looped to Rx)
2 - RTS (looped to CTS)
3 - Rx (looped to Tx)
4 - CTS (looped to RTS)
5 - x (open)
6 - x (open)
7 - x (open)
8 - GND (open)
9 - x (open)

Any help with this much appreciated!

Post Reply

Return to “General fitlet2 questions”