System clock lose

Posts: 1
Joined: Thu Jul 02, 2009 12:08 pm

System clock lose

Post by staratlas »

Hi, everyone.

I use Windows XP Pro SP3 on fit-PC2.

System clock usually lose correct time.
Slowing of clocks about 10 sec per 1 min.

Second hand of sytem clock sometimes
stopped 2 or 3 sec on same position.

Please advice me about this problem. Thank you.


Re: System clock lose

Post by irads »

Check clock in CMOS without starting Windows to tell if it's a HW or SW issue.

Posts: 3
Joined: Tue Jun 02, 2009 12:31 pm

Re: System clock lose

Post by ajalger »

I'm having a similar issue.. after my fit-pc2 is up for about a week i've noticed the clock can be 20-30mins off.. I'll probably just find a way to sync the clock more often.

Posts: 1
Joined: Wed Sep 30, 2009 12:08 pm

Re: System clock lose

Post by jmark »

Yup, this is happening to me too... this is obviously a common issue. My system clock has lost nearly 50 minutes overnight!

Any idea why this would be happening?

Posts: 2
Joined: Wed Sep 30, 2009 3:35 pm

Re: System clock lose

Post by jabben »

Hi everyone,

I've got the same problem on my pre-installed Ubuntu. I'm running ntpd which I thought should help adjusting any differences. But after a couple of hours after restart the drift is huge:

Code: Select all

$ ntpq -nc peers
    remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================    2 u   18   64  377    6.127  464874. 3453.31    2 u   34   64  377    6.530  470486. 5235.08    2 u   64   64  377   28.907  462855. 4256.39   .PPS.            1 u    9   64  377    8.568  463847. 4289.22
This is a real problem because it affects SSH sessions etc. Does anyone know what to do?


Posts: 2
Joined: Wed Sep 30, 2009 3:35 pm

Re: System clock lose

Post by jabben »

Hi again,

It seems that I've solved the drift by replaceing NTPD with chrony instead. The clock been correct now for 5 days. And I am happy.


Posts: 17
Joined: Thu Oct 15, 2009 8:13 pm

Re: System clock lose

Post by morgad »

I could not get ntpd to work reliably (it kept stepping the clock every 10 minutes), as the machine came with an ntp 'drift' file (/var/lib/ntp/ntp.drift) already installed. Once I had stoped nptd, deleted the drift file, and restarted ntpd things settled down inside an hour.

The 'drift' value for my machine is totally different to that on the machine that generated the original drift file - did this file come with the fit-pc disc image, or was it part of the package I installed from ubuntu 8.04 LTS ?

(and shouldn't nptd be installed by default anyhow nowadays?)


Posts: 1
Joined: Thu Nov 26, 2009 10:53 am

Re: System clock lose (solved)

Post by veceru »

I am having the same problem under Windows XP.

I solved it by changing the NTP client poll interval. It is a week by default, I changed it to 1 hour.

How to do it:

Edit the following registry key:

It will contain a DWORD value of 604800 seconds (one week). Change it to 3600.

Then you'll need to restart the time service. Go to "Control Panel" -> "Administrative Tools" -> "Services" -> "Windows Time" stop and restart it. Please note that it can have a different name if your language is not English. For example in Spanish is: "Horario de Windows".

As alternative, just reboot after changing the registry key.

I found the original idea here: ... requently/

Anyway, any idea about why is happening this strange behaviour?

Posts: 7
Joined: Wed Sep 23, 2009 2:14 pm

Re: System clock lose

Post by redada »

Same Problem here on Archlinux.

Is there any fix for this, besides using a ntp-service?


Posts: 2
Joined: Wed Dec 30, 2009 3:54 am

Re: System clock lose

Post by jrmole »

I am seeing the same behavior with a clean install of Ubuntu 9.10. The clock falls behind 1-2 hours per day, but not evenly. Sometimes it will hold the right time for hours, then suddenly drop 10-20 minutes. It has never gone 24 hours without loosing sync.

Since I am trying to use this machine as a data logger, this is a huge problem for me. Sometimes when it jumps, it misses running chron jobs entirely.

I've set network time checks to be more frequent updates without much luck. Recently, I swapped out ntp for chrony, but that didn't help either.

Desperately looking for a solution...

Post Reply

Return to “RTC & System clock”