Multilan and quad Intel 82574L stop working

Post Reply
rcoll
Posts: 1
Joined: Fri Oct 25, 2013 7:02 pm

Multilan and quad Intel 82574L stop working

Post by rcoll »

Hi Everybody,

I recently bought the Multilan version of the Intense PC and got hit by a strange bug affecting Intel quad interface with NIC 82574L which may in certain circumstances completely stop to work !

Google returns a few interesting links about that like this one :
http://blog.krisk.org/2013/02/packets-of-death.html

and in the comment to this post I was able to find a post pointing to sourceforge where a script exists to correct impacted EEPROM :
http://sourceforge.net/projects/e1000/f ... _or_82583/

Run on my Multilan server :
# ./fixeep-82574_83.sh eth2
eth2: is a "82574L Gigabit Network Connection"
This fixup is applicable to your hardware
executing command: ethtool -E eth2 magic 0x10d38086 offset 0x1e value 0x5a
Change made. You *MUST* reboot your machine before changes take effect!

If this may be of any help to other happy Multilan Intense PC owners...

Have a nice day,
Raphael

irads
Site Admin
Posts: 2365
Joined: Mon Mar 16, 2009 2:11 pm

Re: Multilan and quad Intel 82574L stop working

Post by irads »

Thanks for sharing.
-------------------------
Irad Stavi
Forum admin

-------------------------

opencompany
Posts: 100
Joined: Tue Apr 21, 2009 10:41 am

Re: Multilan and quad Intel 82574L stop working

Post by opencompany »

Has this bug been solved permanently in current hardware revisions?

Thank you.
Kind Regards,
Kevin Peter Gade

CompuLab Nordic A/S (www.compulabnordic.dk)
Danish distributor of fit-PC and other products from CompuLab since 2008.

Post Reply

Return to “Ethernet”