Automatic power up on USB with Logitech camera

Post Reply
jens
Posts: 32
Joined: Thu May 07, 2009 2:32 pm

Automatic power up on USB with Logitech camera

Post by jens »

I have come across a very strange problem. When I have
a Logitech camera plugged into the either of the rear USB 2.0
ports, the machine powers up about 3 seconds after being shut down
(shutdown via software). If I move the camera to any of the front USB 2.0
ports, the machine shuts down and stays off.

I have two IPCs and have tested both with two different Logitech cameras.
Also, when I have keyboard/mouse plugged into the same rear ports,
the machine stays off.

I should mention that I run Linux Mint 17.3 on both machine (have also tried Fedora23).
And the typical command given is "shutdown -h now" or by the "Shutdown" menu option.

Is there some sort of "power up on USB" in the BIOS that fires because of some
left over static in the camera?

Jens

jens
Posts: 32
Joined: Thu May 07, 2009 2:32 pm

Re: Automatic power up on USB with Logitech camera

Post by jens »

Update: The issue does not show up when using Windows 10.
I assume it is a Linux problem, so I will re-post my question there.

mbirger

Re: Automatic power up on USB with Logitech camera

Post by mbirger »

It may have some connection to USB power functionality on Intense PC:
http://fit-pc.com/wiki/index.php/FAQ:In ... r_behavior

Intense PC USB port power behavior:
1. FACE Module ports – USB power always on (S0, S3, S4, S5).
2. Motherboard back panel ports – USB power on in S0, S3 but off in S4, S5.

S0 – active
S3 – sleep
S4 – hibernate
S5 – shutdown

And of course may be relevant to OS/SW settings.

jens
Posts: 32
Joined: Thu May 07, 2009 2:32 pm

Re: Automatic power up on USB with Logitech camera

Post by jens »

Solution found (very linux specific):

It seems to be related to the power saving features for USB in Linux.
What lead me to the solution was that I got a lot of messages like
usb 3-1.6: reset high-speed USB device number 4 using ehci-pci
in the log (which was slowing down the backgammon game gnubg!!!).

I changed a line in /etc/default/grub to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1"
and ran sudo grub-update.

Upon reboot the messages above were gone and now the machine powers off as it should.

Post Reply

Return to “USB”